These forums are locked and archived, but all topics have been migrated to the new forum. You can search for this topic on the new forum: Search for wordpress 3.2 and PHP version on the new forum.
I've installed the latest virtualmin update and it upgraded my wordpress script installer from 3.1.3 to 3.2.
wordpress 3.2 requires a newer version of PHP. I am running Cent OS 5.4 and PHP 5.1.6.
When I attempt to update the PHP package I get a message back saying that I have the latest version and there is nothing to do.
Any way to force an upgrade, or do I need to upgrade Cent OS before I get the latest PHP, or can I go back to the 3.1.3 wordpress script?
Hmm, that's a bit of a pickle :-)
What version of PHP does WordPress 3.2 require? The Install Script will need to be configured to catch that.
In the meantime -- you can upgrade to PHP 5.2.17 by using the Virtualmin bleed repository:
Wordpress 3.2 wants PHP 5.2.4 or higher
Best solution for me would be to go back to the wordpress 3.1.3 install script. Any way to do that?
When I try to update PHP 5.1.6 to 17 via the Virtualmin bleed repository with "yum update php*" I get:
--> Finished Dependency Resolution php53-common-5.3.3-1.el5_6.1.x86_64 from updates has depsolving problems --> php53-common conflicts with php-common Error: php53-common conflicts with php-common
I wonder - do I need to uninstall PHP first?
Hmm, what output do you get if you run this command:
rpm -qa | grep php
It almost looks as if you may have PHP 5.3 installed already, but the above command should show what's going on there :-)
I get this Eric:rpm -qa | grep php
Alright, the issue isn't what I thought it was... this is going to take a few posts to resolve, and I'm going to get really confused trying to do that in the middle of this other thread :-)
Could you start a new forum thread, including the two posts you have above, and we'll take this discussion over to that new thread :-)
Sorry, I'm not aware of a way to downgrade the WordPress version :-/
We're talking about pushing out a new Virtualmin version here soon to prevent such upgrades for other folks, but I know that won't help anyone such as yourself who already has.
I'll offer that the PHP version in the Virtualmin repository is pretty well tested, a lot of folks are using that -- so that should work well for you.
I know that's not ideal, but I'm not sure I have another good suggestion as for what to do...
Wordpress 3.2 wants PHP 5.2.4 or higher. Your note says the the virtualmin repository has 5.2.17, so I do not see how that will help me.
5.2.17 is actually newer than 5.2.4 -- the 17 is more recent than the 4.
5.2.17 is the most recent 5.2 release... 5.2.4 was released in August of 2007, 5.2.17 was released in January of 2011. You can see those details here:
So, that should do the trick for you!
I guess I'm taking those numbers too literally, thinking there must be a missing zero or something.
I would have expected it to be 5.2.04 if they were going to allow 5.2.17 to be greater, but hey what do I know. I guess i'll just have to research the release dates in the future.