Script Installer Upgrade Warning

I just ran the script installer upgrade for MediaWiki on all virtual servers. After the upgrades were done, the title pages of all wikis show

MediaWiki 1.31 internal error MediaWiki 1.31 requires at least PHP version 7.0.0 or HHVM version 3.18.5, you are using PHP 5.5.9-1ubuntu4.25. Supported PHP versions Please consider upgrading your copy of PHP. PHP versions less than 5.6.0 are no longer supported by the PHP Group and will not receive security or bugfix updates. If for some reason you are unable to upgrade your PHP version, you will need to download an older version of MediaWiki from our website. See ourcompatibility page for details of which versions are compatible with prior versions of PHP.

A script installer upgrade must show a warning, before it is leaving a software in an unusable state.

Is there a way to downgrade all MedaWiki instances to the last working version?



Howdy -- thanks for contacting us, and sorry you ran into that issue!

We have a system in place for handling PHP version requirements, I suspect we just didn't realize that was an issue with that MediaWiki version.

Unfortunately, there's no real way to downgrade.

Do you happen to have PHP 7 on your server? As that would be one way to solve that, if that would work for your domains. On that distro, you should be able to install it side-by-side with PHP 5.

Alternatively, you may have to revert to a backup.

Jamie will look into the PHP version requirements in the meantime though!

Unfortunately "side-loading" PHP 7 does not work / needs too much fine tuning. I installed everything according to the "how can I have PHP 7 on my Ubuntu 14.04" articles and I ended up with updates that broke Apache. As the server is a production server, I am now forced to find a way to quickly upgrade to the latest Ubuntu release in order to get all the wikis back up. sigh