Script installer doesn't support php > 5.4

I've updated php packages to 5.4 (by using remi repo on centos OR dotdet repo on debian) , but when I want to install phpmyadmin it says : "This script cannot be installed, as it requires PHP version 5."

I have to open /etc/webmin/virtual-server/latest-scripts/, edit lines 71 to 76 as follows :

        if (!$phpv) {
#               push(@rv, "Could not work out exact PHP version");
        elsif ($phpv < 5.2) {
#               push(@rv, "phpMyAdmin requires PHP version 5.2 or later");


That seems like a hack around the real problem, which is that Virtualmin isn't detecting PHP 5 properly.

If you click on System Information on the left menu and open the "Program" section, what does it say next to "PHP version" ?

Mostafa's picture
Submitted by Mostafa on Sun, 10/20/2013 - 23:25

I couldn't find program in System information of VirtualMin GPL.

Are you sure you don't see a collapsible section titled "Programs" on the right-hand frame after clicking "System Information" ?

Mostafa's picture
Submitted by Mostafa on Mon, 10/21/2013 - 14:26

Of course I'm sure. Screenshots attached.

That's unusual - it looks like part of the right frame is missing.

Does it help if you click "Refresh system information" ?

Mostafa's picture
Submitted by Mostafa on Tue, 10/22/2013 - 01:50

No it doesn't. I usually use 3rd party repositories and also modify virtualmin settings (disabling quotas, installing php-fpm+apache2.4, ...).

I'm receiving a fresh ded server this weekend and I'll check if the Programs tab is missing on fresh centos 6 x64 virtualmin GPL installation or not and then update the issue.

Another way you could check which PHP versions Virtualmin detects is to SSH in as root and run :

virtualmin check-config

It should output something like :

The following PHP versions are available : 4.4.8 (/usr/bin/php4), 5.2.9 (/usr/bin/php-cgi), 5.4.11 (/opt/rh/php54/bin/php-cgi)
Mostafa's picture
Submitted by Mostafa on Wed, 10/23/2013 - 01:42

I'm receiving :

The following PHP versions are available : 5.4.20 (/usr/bin/php5-cgi)

Ok, so it looks like PHP 5 is being detected OK. Is phpMyAdmin still failing to install?

If so, we may need to take a look at your system directly to see what is going wrong here.

Mostafa's picture
Submitted by Mostafa on Wed, 10/23/2013 - 13:17

Do you need root access? How can I send you the details?

any way how to fix this problem?

i have: The following PHP versions are available : 5.5.9 (/usr/bin/php5-cgi)

but still:

This script cannot be installed, as it requires PHP version 5. This script cannot be installed, as this virtual server does not meet its requirements : Could not work out exact PHP version

Virtualmin 5 on ubuntu 14.04

Try going to the Server Configuration -> Website Options page for that domain, and checking for any errors under "PHP information"

Thanks for reply.

PHP versions installed No versions found!

at all my domains. yet sure i have php :D.

I have apache 2.4.7 php 5.5.9 all setup with php5-fpm pools. everything is working except phpmyadmin..

Is the PHP execution mode for this domain set the fcgid?

It wasnt because i am using php5-fpm. After your question i made it and my phpinfo screen changed from fpm/fastcgi to cgi/fastcgi.

Any suggestions?

Ok :D I fixed it. Even Fastcgi selected and fpm is active. yet my vhost file is little messed up.

This one is working;

##ScriptAlias /cgi-bin/ /home/temha/cgi-bin/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory /home/temha/public_html>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted
##AddType application/x-httpd-php .php
##AddHandler fcgid-script .php
##AddHandler fcgid-script .php5
FCGIWrapper /home/temha/fcgi-bin/php5.fcgi .php
FCGIWrapper /home/temha/fcgi-bin/php5.fcgi .php5
AddHandler fastcgi-script .fcgi
AddHandler php5.fcgi .php
AddHandler php5.fcgi .php5
FCGIWrapper /usr/lib/cgi-bin/php5-temha.fcgi .php
FCGIWrapper /usr/lib/cgi-bin/php5-temha.fcgi .php5

But there is some logical errors and some how apache is avoing them. Could you or someone re write my messed vhost for me :D?


apache has fcgi and fcgid modules. virtualmin doesnt recongise fcgi module. if i am right php-fpm can only work with mod_fcgi, right?

if yes virtualmin wont recongise.


Right now, Virtualmin doesn't support php-fpm at all - so if you've manually edited your Apache config to use it, this may interfere with Apache version detection.

Definitely that's the problem. I temporarily activated fcgid and installed necessary scripts and revert back to php-fpm. everything is fine now :D

For the people who has the same problem about phpmyadmin which i have mentioned above is possible to fix with editing the tag "pmaabsoluteuri" in