You should upgrade to MySQL 5.0.15 or later

After upgrading phpmyadmin to latest release available in virtualmin script interface, I hade an error page very clear:

phpMyAdmin - Error
You should upgrade to MySQL 5.0.15 or later.

Is it possible to upgrade MySQL to version 5 or later ?
following system info:
Operating system CentOS Linux 4.8
Perl version 5.008005 Path to Perl /usr/bin/perl
Postfix version 2.2.10
Mail injection command /usr/lib/sendmail -t
BIND version 9.2.4
Apache version 2.0.53
PHP version 4.3.9, 5.2.6
Logrotate version 3.7.1
MySQL version 4.1.22
PostgreSQL version 7.4.26
ProFTPd version 1.30
SpamAssasssin version 3.2.4
ClamAV version 0.92

Closed (works as designed)


Joe's picture
Submitted by Joe on Mon, 10/26/2009 - 05:36 Pro Licensee

We don't provide the MySQL package on CentOS 4. We do have a bleeding edge package repository for CentOS 5, but providing a similar service for CentOS 4 would be way too difficult; because CentOS 4 is such an old base to build on, it would take a huge amount of work to bring the full dependency chain up to date, and that would be asking for compatibility and stability problems. It's just not something we could take on (we're not an OS provider; that's what you have the CentOS folks for).

In short: If you want new packages, you'll need to upgrade to a newer OS version.

Or, less recommended but requiring less downtime: You could run the MySQL packages provided by the MySQL folks. They have been reported to work fine (with configuration tweaks in Webmin) with Virtualmin, though I have no personal experience with them.