phpMyAdmin 3.2.1 won't install

If I run the phpMyAdmin 3.2.1 install script, it fails to install saying it "requires PHP v5.2 or later". My system shows it is running PHP 5.1.6-23.2.el5_3, which its also says is the latest release, so I can't update via Vmin/Webmin. I can install the old phpMyAdmin script (only other version available). Is this a CentOS 5 specific issue or ...



Howdy -- unfortunately, that version of phpMyAdmin does require a newer version of PHP than comes with CentOS 5.x.

Your options are to stick with the older branch, as you mentioned, or you can give the CentOS bleeding edge repository a shot -- it contains a much newer version of PHP.

Details on the bleeding edge repository are available here: